iOS Video Ad Bug
0

Started by Zandon,

27 posts in this topic

Posted

Seit der 0.1.8 habe ich das "Problem" das man beim boost immer 2 Videos gucken muss. 

Man klickt auf den Diamanten, wählt sein boost und das Video wird abgespielt. Danach kommt ein Fenster mit einem Zahnrad , Haken und x symbol und man muss sich noch mal ein Video anschauen um den boost freizuschalten.

 

Gewollt oder Bug?

(Ios Version)

1

Share this post


Link to post
Share on other sites

Posted

Ich hoffe doch sehr auf bug, das is iwie hart annoying

0

Share this post


Link to post
Share on other sites

Posted (edited)

Fun fact: If you X out of the second video the next time you try to boost one video is enough. Maybe that helps with pinning it down.

Edit: Mir ist noch was auf gefallen, die Produktion scheint stark gebremst waehrend die videos laufen, ich habe gerade ein sehr aktives setup mit 528 Waren pro minute, mir muesste also waehrend 2 adds gehoerig das lager voll laufen. Tut es aber nicht.

Edited by Aristai
0

Share this post


Link to post
Share on other sites

Posted

Seit der 0.1.8 habe ich das "Problem" das man beim boost immer 2 Videos gucken muss. 

Man klickt auf den Diamanten, wählt sein boost und das Video wird abgespielt. Danach kommt ein Fenster mit einem Zahnrad , Haken und x symbol und man muss sich noch mal ein Video anschauen um den boost freizuschalten.

Uhhhh, das soll aber nicht so sein. 
Der Ablauf ist normalerweise folgender:

1) In Castle Screen gehen -> Ad wird im Hintergrund requested
2) Click auf Diamand Symbol -> SIcherheitsabfrage geht auf
3) Zahnradfenster geht auf -> Es wird gecheckt ob die Ad ready ist und maximal 4 Sekunden gewartet
4) Wenn die Ad ready ist, geht das Fenster zu und ein Video wird gespielt
5) Boost wird an den Spieler gegeben.

Ein Video gucken suckt ja schon, zwei wäre etwas sehr hart :)
Wir investigaten das sofort. 

- Kann das jemand auf Android auch reproduzieren oder ist das ein iOS only Issue?
- Passiert das jedes mal oder nur vereinzelt?

Edit: Mir ist noch was auf gefallen, die Produktion scheint stark gebremst waehrend die videos laufen, ich habe gerade ein sehr aktives setup mit 528 Waren pro minute, mir muesste also waehrend 2 adds gehoerig das lager voll laufen. Tut es aber nicht.

Ich teste das mal, aber das ist natürlich nicht gewollt.

 

 

 

0

Share this post


Link to post
Share on other sites

Posted (edited)

Schraubt ihr gerade am Server? Ich sehe jetzt das folgende: erster Boost funktioniert, zweiter Boost stuerzt ab, Absturz deaktiviert ersten boost.

Dafuer laeuft die Produktion jetzt beim ersten Boost weiter, beim Absturz ist nach dem Neustart immer das Lager voll auch wenn es nur 10 sekunden dauert.

 

Kleines Update: Mir ist gerade aufgefallen das die Zeit bei Abstuerzen rueckwaerts laeuft. Das Lager ist voll weil man vor den letzten verkauf zurueck gesetzt wird, deshalb geht auch der vorherige Boost verloren

Edited by Aristai
0

Share this post


Link to post
Share on other sites

Posted

Bei mir gehts.

0

Share this post


Link to post
Share on other sites

Posted

Das sieht bisher nach einem iOS only Bug aus. Der Bug könnte durch die neue Cheat Protection verursacht worden sein. Beim Werbung gucken verlässt du ja kurz das Spiel und kommst danach wieder zurück. Da scheint die Zeitmessung durcheinander zu kommen.
Ist in Bearbeitung.

0

Share this post


Link to post
Share on other sites

Posted

Bei mir tritt das immer auf. 

 

Was auch ärgerlich ist, das ich ein seit 3-4 Tagen maximal 5-6 boosts überhaupt nutzen kann. Weil er bestimmt zu 75% der Zeit sag, das kein Video vorhanden sei. 

 

1

Share this post


Link to post
Share on other sites

Posted

Seit der 0.1.8 habe ich das "Problem" das man beim boost immer 2 Videos gucken muss. 

Man klickt auf den Diamanten, wählt sein boost und das Video wird abgespielt. Danach kommt ein Fenster mit einem Zahnrad , Haken und x symbol und man muss sich noch mal ein Video anschauen um den boost freizuschalten.

 

Gewollt oder Bug?

(Ios Version)

Das war ein übler Bug, der auch tatsächlich nur auf iOS autritt. Der sollte jetzt mit der Version 0.1.9 gefixed sein - die befindet sich gerade im Apple Review und wird hoffentlich bald online gehen.

Dass es oft keine Videos gibt, liegt, bzw. lag daran, dass wir auf iOS kurzfristig weniger Ad Anbieter haben, als auf Android. Das wird in den nächsten Tagen behoben (dafür ist kein weiteres Update nötig, da das server-seitig passiert)

Danke fürs Melden!!

0

Share this post


Link to post
Share on other sites

Posted (edited)

Bad news: die doppelvideos sind immernoch da! Bzw wollte er mir grad n 2. video andrehn, hat dann aber erklärt "keins verfügbar" -> kein boost

könnte n zufälliger ausreißer sein, ich klick ma noch n bissl auf dem boostknopf

 

intressant 7x oben beschriebenes phänomen, 1x boost nach dem 1. vid, dann wieder oben beschriebenes phänomen. Könnte evtl am adanbieter liegen ?

ich beschuldige jetz einfach mal unity ads, da taucht der fehler auf jeden fall auf. Und das "die produktion hält an, während videos laufen"-phänomen kann ich ebenfalls bestätigen 

ok, ich gebs auf n muster zu suchen... grade hat n vid von unity einwandfrei funktioniert, dafür is jetz angeblich überhaupt kein vid mehr verfügbar

Edited by Antibruder
0

Share this post


Link to post
Share on other sites

Posted

bei mir funktioniert gerade das Ads-gucken nicht bzw bonus wird nicht aktiviert.

Wenn ich auf den Diamant klicke und mein Bonus aussuchen wird das Video abgespielt.

Ich schließe es am ende über X wie immer.

Anschließend lande ich in der Boost übersicht und es ist kein Boost aktiv

 

ios 0.1.9

0

Share this post


Link to post
Share on other sites

Posted

Jo Bug ist verschlimmbessert. Jetzt spielt das erste Video ab. Dann wieder Zahnrad mit x und Haken . Man klickt auf Haken und die Meldung"keine Videos verfügbar" kommt. 

Und kein boost ist aktivierbar

0

Share this post


Link to post
Share on other sites

Posted

Bei mir ist gerade eine geheimnisvolle Version 0.2 aufgetaucht. Und ich konnte beim ersten Versuch mit je einem Video beide boostslots nutzen. Testerboxhandschuhe raus. Mal schauen wie wir das kaputt kriegen.

1

Share this post


Link to post
Share on other sites

Posted

Ja kann ich bestätigen. 

Mit Version 0.2.0 klappt das wieder mit den boost

1

Share this post


Link to post
Share on other sites

Posted

Bei mir ist gerade eine geheimnisvolle Version 0.2 aufgetaucht. Und ich konnte beim ersten Versuch mit je einem Video beide boostslots nutzen. Testerboxhandschuhe raus. Mal schauen wie wir das kaputt kriegen.

Haha, ui das ist eine Erleichterung. Die Version 0.2 haben wir gestern abend noch hoch geladen, um den Ad Bug und den Zeit Bug zu fixen. Die wollten wir nicht übers ganze Wochenende im Spiel lassen. Wir waren dann aber zu müde, um noch einen entsprechenden Update Post zu machen.

Und ja bitte melden, wenn da immer noch was schief läuft!

0

Share this post


Link to post
Share on other sites

Posted

Nach ausgiebigem Boosten (eigentlich hätte ich den autokorrekt auf borsten drin lassen müssen) kann ich sagen das System funktioniert im grossen und ganzen besser als jemals zuvor. Der ein oder andere Crash ist mir leider aber immer noch untergekommen, sowohl mit als auch ohne das der Spielstand zurückgesetzt wird. Da ich keinerlei Ad anbietet oder sonst irgendwas sehe, kann ich nur hoffen das ihr auf eurer Seite irgendwas erkennen könnt.

0

Share this post


Link to post
Share on other sites

Posted

Nach ausgiebigem Boosten (eigentlich hätte ich den autokorrekt auf borsten drin lassen müssen) kann ich sagen das System funktioniert im grossen und ganzen besser als jemals zuvor. Der ein oder andere Crash ist mir leider aber immer noch untergekommen, sowohl mit als auch ohne das der Spielstand zurückgesetzt wird. Da ich keinerlei Ad anbietet oder sonst irgendwas sehe, kann ich nur hoffen das ihr auf eurer Seite irgendwas erkennen könnt.

Geht der spielstand komplett verloren, oder wird er nur auf einen früheren zurück gesetzt? Wenn ich den Crash nicht finden kann (der leider vom Ad Anbieter selber verursacht sein kann), kann ich vielleicht zumindest den Spielstand reset verhindern, wenn ich das Problem identifizieren kann.

0

Share this post


Link to post
Share on other sites

Posted

Geht der spielstand komplett verloren, oder wird er nur auf einen früheren zurück gesetzt? Wenn ich den Crash nicht finden kann (der leider vom Ad Anbieter selber verursacht sein kann), kann ich vielleicht zumindest den Spielstand reset verhindern, wenn ich das Problem identifizieren kann.

Er ging noch nie komplett verloren, es sieht so aus als wuerde man zu einem relativ beliebigen safe spot zurueck gesetzt, meist ist das vor dem letzten Verkauf. Aber das koennte ein roter Hering sein. Klassischer weise ist man laenger afk, hat das lager voll, verkauft alles und moechte dann die Produktion mit Boosts ankurbeln da man vor hat die naechsten 15 Minuten aktiver zu spielen. Richtig mies ist das wenn man mehrere Boost slots kombiniert und der letzte crasht, dann sind die anderen Boosts die funktioniert haben weg.

Gestern abend hatte ich allerdings 2 crashs bei denen das Spiel nicht zurueck gesetzt wurde und der erste Boost korrekt aktiv war wenn der zweite crashte.

Ansonsten kann ich nur noch hinzufuegen das ich zur zeit 97/100 Boosts fuer die 100 Boosts quest habe, 35 davon auf 0.1.9 darunter 4 crashes.

1

Share this post


Link to post
Share on other sites

Posted (edited)

Heute Abend hat sich ein neuer geselle im Zoo der ad bugs eingeschlichen: Das Video lädt nicht aber der Boost zählt, die Zeit springt ein wenig nach vorne, einmal um ganze 8 Minuten. Solltet ihr am Server geschraubt haben ist das eine deutliche Verbesserung, sozusagen bankirrtum zu ihren Gunsten anstatt andersrum.

Es kann natürlich auch sein das die Ad anbieter kaputtes material Regelmäßig aussortieren und so das verhalten im Spiel immer leicht ändern.

Betroffen waren alle Boosts zwischen 10pm und 11pm EDT insgesamt 4

Edited by Aristai
1

Share this post


Link to post
Share on other sites

Posted

Es sind leider immer noch nicht ganz alle Bugs ausgemerzt.. wie es scheint, kann das Spiel nicht immer ganz zuverlässig feststellen, ob eine Internet Verbindung besteht. Und wenn keine besteht, dann wird das dem Spieler nicht richtig mitgeteilt.

0

Share this post


Link to post
Share on other sites

Posted

ich weiß nicht, obs an der comischen coin-werbung von chartboost liegt, oder obs n bug der app ist, jedenfalls ist mit genannter werbung das doppelvideo-"feature" wieder da

0

Share this post


Link to post
Share on other sites

Posted

ich weiß nicht, obs an der comischen coin-werbung von chartboost liegt, oder obs n bug der app ist, jedenfalls ist mit genannter werbung das doppelvideo-"feature" wieder da

Ich hab seit gestern auch nur noch coin-werbung von chartboost. Einfach sofort wegblicken und 5-10 Sekunden warten, dann wird der Boost aktiv. Das ist zwar nicht der Sinn der Sache, aber kein echter doppelvideo bug.

0

Share this post


Link to post
Share on other sites

Posted

so war das anfangs... wenn ich das jetz so mach, dann will er noch ne werbung laufen lassen... wenn ich auf den "get coin" button klick läuft n vid und alles funktioniert problemlos. man sollte evtl dazusagen, dass ich die letzten tage excessiv geboostet hab...^^

0

Share this post


Link to post
Share on other sites

Posted

Das waers ja, ich hab in den letzten Tagen auch gut reingehauen für den dritten Boost slot. Jetzt sieht es so aus das ich auch bei "normalen" adds wo das video direkt startet ein paar Sekunden nach ende des videos habe wo ich den Haken ein zweites mal klicken könnte. Hab ich aber noch nie gemacht, der Boost wird weiterhin Ordnungsgemäß aktiv wenn man das aussitzt.

0

Share this post


Link to post
Share on other sites

Posted

Ich denke ich habs jetzt: Wenn man den Boost startet kommt die Watch a video confirmation box mit dem Zahnrad wo man ja oder nein klicken kann.

Man klickt den Haken, das spiel geht in den Hintergrund und das video läuft. Ich mache das video zu und komme ins Spiel zurück wo dann mein Boost aktiv ist.

Die Boost dauer die ich im Spiel sehe wenn es wieder im Vordergrund ist ist im Normalfall 3 Sekunden unter der tatsächlichen Boostdauer, das ist die Zeit die das Spiel braucht um wieder reinzukommen. Allerdings ist da etwas auf 30 Sekunden videos optimiert. Bei diesen funktioniert alles einwandfrei. Ist das Video kürzer ist die confirmation box noch da, und ich kann durch erneutes klicken auf den Haken ein zweites video starten. Diese coin Werbung ist quasi instant da es ein zweistufiges System ist aber bei den gelegentlichen 15 und 20 Sekunden videos kann man den Effekt in leicht abgemilderter Form ebenfalls beobachten. Und genau dann wenn ich meine Theorie noch ein wenig testen möchte, kriege ich 4 30 Sekunden videos in Folge. 

1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
0